حالة الموضوع:
مغلق
  1. .:: RSS ::.

    .:: RSS ::. عضوية آلية

    الأنتساب:
    ‏9 سبتمبر 2011
    المشاركات:
    14,005
    الإعجابات المتلقاة:
    0
    نقاط الجائزة:
    36
    الإقامة:
    IQ-T34M
    السلام عليكم ..
    طبعاً الكل يعرف أن هناك تعارض مع الأدوات وتحديثات الأدوات سواء ف الميتاسبلويت او غيرها اليوم واجهتني مشكله من خلال تثبيتي ل أداه لحوم البقر خخ
    الـ beef
    وماراح يعمل الا على الباكيج روبي 1.9
    طبعاً
    برمجت سكربت بسيط && لتحميل والتنصيب كل مايحتاجه الروبي ع جهازك .. :d
    كود PHP:
    #!/usr/bin/env python
    from os import system as ruby
    import time
    import sys
    def title
    ():
    print
    '''
    #---------------------------------------#
    #&&&&&&&&&& author;fahad-alharbi &&&&&&&#
    #***************************************#
    #^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^#
    #@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@#
    install Ruby 1.9
    '''


    title()
    time.sleep(10)

    def install():
    ruby('sudo apt-get uninstall ruby1.8 ruby ');
    ruby('sudo apt-get install ruby1.9.1 ruby1.9.1-dev');
    ruby('sudo ln -s /usr/bin/ruby1.9.1 /usr/bin/ruby');
    ruby('http://production.cf.rubygems.org/rubygems/rubygems-1.8.24.tgz');
    ruby('tar xvzf rubygems-1.8.24.tgz ');
    ruby('cd rubygems-1.8.24/');
    ruby('sudo ruby setup.rb');
    ruby('sudo ln -s /usr/bin/gem1.9.1 /usr/bin/gem')
    ruby('sudo gem install bundler')
    install()


    ruby -v

    ruby 1.9.2p0 (2010-08-18 revision 29036) [i686-linux]

    فمان الله :d


     
حالة الموضوع:
مغلق

مشاركة هذه الصفحة